No thumbnail with NEF files

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
TD
Posts: 29
Joined: Sun Dec 02, 2007 11:41 am

No thumbnail with NEF files

Post by TD » Wed Dec 12, 2007 5:37 pm

The thumbnails of NEf files made by my camera are displayed correctly. But when I open a JPEG file with Nikon Capture NX and save it as a NEF. I see no thumbnail in the browser view and only a very small picture in the preview on my second monitor.

Other software displays the same file correctly.

User avatar
xnview
Author of XnView
Posts: 31747
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: No thumbnail with NEF files

Post by xnview » Wed Dec 12, 2007 7:04 pm

TD wrote:The thumbnails of NEf files made by my camera are displayed correctly. But when I open a JPEG file with Nikon Capture NX and save it as a NEF. I see no thumbnail in the browser view and only a very small picture in the preview on my second monitor.

Other software displays the same file correctly.
You can see the thumbnaisl because XnView can extract the thumbnail, but can't read the picture
Pierre.

TD
Posts: 29
Joined: Sun Dec 02, 2007 11:41 am

Post by TD » Wed Dec 12, 2007 9:27 pm

The problem is that I do not see a thumbnail in the browser and only a very small thumbnail in the preview.

TD
Posts: 29
Joined: Sun Dec 02, 2007 11:41 am

Post by TD » Wed Jan 02, 2008 11:27 am

Have to bring this up again because it is very anoying to have no thumbs in the browser view.

I understand, that XnView cannot read the picture, sad..., but ok. But why there is not thumbnail in the browser view?

I don'understand.

User avatar
xnview
Author of XnView
Posts: 31747
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Wed Jan 02, 2008 2:19 pm

TD wrote:Have to bring this up again because it is very anoying to have no thumbs in the browser view.

I understand, that XnView cannot read the picture, sad..., but ok. But why there is not thumbnail in the browser view?

I don'understand.
If you don't have 'recognise only by extension', xnview try to build thumbnail from the file by reading the header. The header for RAW file is similar to a TIF.
Pierre.

TD
Posts: 29
Joined: Sun Dec 02, 2007 11:41 am

Post by TD » Wed Jan 02, 2008 6:20 pm

But I have 'recognise only by extension' and all my NEF files are perfectly displayed.

Only the NEF's that I made by opening a JPEG file with Nikon Capture NX and saving it as a NEF make the problems.

If you want, I can sent you such a file, just tell me where to sent it.

User avatar
xnview
Author of XnView
Posts: 31747
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Jan 03, 2008 10:02 am

TD wrote:But I have 'recognise only by extension' and all my NEF files are perfectly displayed.

Only the NEF's that I made by opening a JPEG file with Nikon Capture NX and saving it as a NEF make the problems.

If you want, I can sent you such a file, just tell me where to sent it.
Yes, please webmaster at xnview dot com
Pierre.

scw2wi
Posts: 26
Joined: Fri Jul 06, 2007 10:41 am
Contact:

Post by scw2wi » Fri Jan 04, 2008 4:17 pm

If you save JPEG pictures as NEF file,
this is complete different for a NEF RAW-File.

It is a JPEG file with edit steps saved in a NEF format.

Walter
Walter

PSHRutPark
Posts: 137
Joined: Tue Sep 12, 2006 8:38 pm
Location: New Zealand

Post by PSHRutPark » Sat Jan 05, 2008 10:35 pm

TD wrote:But I have 'recognise only by extension' and all my NEF files are perfectly displayed.

Only the NEF's that I made by opening a JPEG file with Nikon Capture NX and saving it as a NEF make the problems.
If I understand your problem and your current settings correctly, I suggest you try turning OFF the "recognise only by extension" option and rebuild the thumbnails.

You may be pleasantly surprised!

PETER

Post Reply