3dsmax thumbnails

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

User avatar
RGhost
Posts: 44
Joined: Sun Mar 30, 2008 10:51 am
Location: Moscow
Contact:

3dsmax thumbnails

Post by RGhost » Tue Apr 01, 2008 10:00 am

:bug: .max (any version of 3dsmax) 3dsmax's thumbnails doesn't preview and doesn't show, since ~1.91 (if I remember correctly)
Can it be fixed?

p.s. Tnx for great viewer! :D
Royal Ghost | http://veda3d.com

User avatar
xnview
Author of XnView
Posts: 33488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 3dsmax thumbnails

Post by xnview » Tue Apr 01, 2008 11:33 am

RGhost wrote::bug: .max (any version of 3dsmax) 3dsmax's thumbnails doesn't preview and doesn't show, since ~1.91 (if I remember correctly)
Can it be fixed?

p.s. Tnx for great viewer! :D
Do you have the Xcompound.dll plugin?
Pierre.

User avatar
RGhost
Posts: 44
Joined: Sun Mar 30, 2008 10:51 am
Location: Moscow
Contact:

Post by RGhost » Tue Apr 01, 2008 1:45 pm

Do you have the Xcompound.dll plugin?
Yes I have. I've just cheked it.

Code: Select all

07.12.2006  18:35            61 440 Xcompound.dll
Now I'm using 1.93.4 - full.
Royal Ghost | http://veda3d.com

User avatar
xnview
Author of XnView
Posts: 33488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Apr 01, 2008 3:43 pm

could you send me a .max file?
Pierre.

User avatar
RGhost
Posts: 44
Joined: Sun Mar 30, 2008 10:51 am
Location: Moscow
Contact:

Post by RGhost » Wed Apr 02, 2008 4:14 pm

In this archive 3 max files saved by different 3dsmax with simple teapot object in scene.
http://veda3d.com/img/maxfiles_4xnview.rar
Royal Ghost | http://veda3d.com

User avatar
xnview
Author of XnView
Posts: 33488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Wed Apr 02, 2008 6:11 pm

RGhost wrote:In this archive 3 max files saved by different 3dsmax with simple teapot object in scene.
http://veda3d.com/img/maxfiles_4xnview.rar
I have the thumbnails for these files, do you have the last version of xnview and xcompound?
Pierre.

User avatar
RGhost
Posts: 44
Joined: Sun Mar 30, 2008 10:51 am
Location: Moscow
Contact:

Post by RGhost » Wed Apr 02, 2008 6:57 pm

I have the thumbnails for these files, do you have the last version of xnview and xcompound?
I'm using 1.93.4 - full

I reseted xnview.ini for sure, nothing happened. Instead of thumbnails form .max files I see white thumbnails.

I'm not sure that it can prevent to show thumbnail:

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.max\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
@="{9DBD2C50-62AD-11d0-B806-00C04FD706EC}"
This registry 3d-party modification allows Explorer to show properly .max thumbnail.
Royal Ghost | http://veda3d.com

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Crash !

Post by Clo » Wed Apr 02, 2008 8:24 pm

:arrow: Pierre

:) Hello !

• I've nine *.max samples here in a folder.
- Testing them with 1.93.4, I get some thumb nails (3…4), but waiting for a ten of seconds,
XnView crashes, and Dear Bill comes to close… :(

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
ouistiti
Posts: 353
Joined: Mon Oct 25, 2004 7:28 pm
Location: Belgique
Contact:

Post by ouistiti » Wed Apr 02, 2008 8:31 pm

I confirm the crash with the Clo's *.max files… :(

Paul
L'important n'est pas de convaincre, mais de donner à réfléchir.
The important thing is not to convince, but to incite to think.

1,77245385090552...

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Tea pot OK

Post by Clo » Wed Apr 02, 2008 8:52 pm

:arrow: Pierre

:) Again…

• The RGhost's files work fine here, I've the thumb nails and no crash…

• However, it's abnormal to get a crash with my own samples, do you wish to get them ?

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 33488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Tea pot OK

Post by xnview » Thu Apr 03, 2008 7:12 am

Clo wrote: • However, it's abnormal to get a crash with my own samples, do you wish to get them ?
Yes please
Pierre.

User avatar
RGhost
Posts: 44
Joined: Sun Mar 30, 2008 10:51 am
Location: Moscow
Contact:

Post by RGhost » Thu Apr 03, 2008 11:55 am

Hm. I install older 1.91 full, it shows (rebuild) thumbnails .max. 1.93.4 not shows.
I don't remember for sure what kind of version xnview stoped to show .max thumbnails.
Royal Ghost | http://veda3d.com

User avatar
ouistiti
Posts: 353
Joined: Mon Oct 25, 2004 7:28 pm
Location: Belgique
Contact:

Post by ouistiti » Thu Apr 03, 2008 2:50 pm

:arrow: RGhost

Try CTRL +H (Toggle the Alpha Channel use)

Here it works perfectly now !

Friendly

Paul
L'important n'est pas de convaincre, mais de donner à réfléchir.
The important thing is not to convince, but to incite to think.

1,77245385090552...

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Samples are sent

Post by Clo » Thu Apr 03, 2008 3:45 pm

:arrow: Pierre

:) Hello !

• I've sent my bunch of *.max files among which one crashes the programme.

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 33488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Apr 03, 2008 4:05 pm

RGhost wrote:Hm. I install older 1.91 full, it shows (rebuild) thumbnails .max. 1.93.4 not shows.
I don't remember for sure what kind of version xnview stoped to show .max thumbnails.
I have no problem with 1.93.4
Pierre.

Post Reply