Clipboard colors error

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, helmut, xnview

User avatar
Drahken
Posts: 884
Joined: Sun Apr 10, 2005 4:29 pm

Clipboard colors error

Post by Drahken »

In both 1.95.2 & 1.95.4 (haven't tried any other 1.95.x versions), when I copy an image to the clipboard from paint shop pro & then paste it into xnview, the colors get washed out (the same way they do if you save an image with the color subsampling set to high). This never happened in versions prior to 1.95.x, and this doesn't happen when I paste the same image into any other imaging program.

This is what the image is supposed to look like:
Image

This is what it winds up looking like:
Image


While most of the image looks ok, you can really see the problem when you look at the colored squares.
User avatar
XnTriq
Moderator & Librarian
Posts: 6354
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq »

User avatar
Drahken
Posts: 884
Joined: Sun Apr 10, 2005 4:29 pm

Post by Drahken »

Lot of clipboard related bugs. Although, I see most of those are related to 1.93.x, while this one is with 1.95.x (it doesn't exist in 1.94.x, I don't have 1.93.x here to test with).
User avatar
xnview
Author of XnView
Posts: 43988
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

In 1.95, i use the CF_BITMAP format, and no more the CF_DIB format. I have problem with clipboard from MSword. Could you send me your email by PM to send a test version?
Pierre.
User avatar
Drahken
Posts: 884
Joined: Sun Apr 10, 2005 4:29 pm

Post by Drahken »

Tried the version you emailed me, and it still has the same problem.
User avatar
xnview
Author of XnView
Posts: 43988
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

Drahken wrote:Tried the version you emailed me, and it still has the same problem.
Have sent another version
Pierre.
User avatar
Drahken
Posts: 884
Joined: Sun Apr 10, 2005 4:29 pm

Post by Drahken »

The second one you sent has fixed the problem.
User avatar
xnview
Author of XnView
Posts: 43988
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

Drahken wrote:The second one you sent has fixed the problem.
Ok, but now a problem with MSword clipboard :-(
Here i use CF_DIB as default, for MSword i use CF_BITMAP (because CF_DIB is not good)...
Pierre.
User avatar
xnview
Author of XnView
Posts: 43988
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Clipboard colors error

Post by xnview »

Please try XnView 1.96 beta
Pierre.