Weird client windows behavior

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
adhimass
Posts: 5
Joined: Mon Feb 09, 2009 10:02 am
Contact:

Weird client windows behavior

Post by adhimass » Thu Feb 12, 2009 10:52 am

First, an unexpected cascaded client window behavior:
How to recreate the problem:
  1. 1. Open two client windows by opening a picture.
    2. Click the Restore Down button (near the client close 'X' button.) The browser and view window will be cascaded. Make their windows smaller by resizing the client windows.
    3. Now open another picture. Suddenly all client window will be maximized. (This is weird #1)
    4. Now close the newly open picture. You'll see the rest of the client windows are maximized, but their contents are as large as the last resize we do on them. (This is weird #2)
Second, a strange vertical separator appear on a maximized window of XnView in Windows Vista.
How to recreate the problem:
  1. 1. Just open the browser and preview a picture. You'll see it on the right side after the picture. Not only on the browser, it also displays when you open a picture. (This is weird #3)

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Re: Weird client windows behavior

Post by ckv » Thu Feb 12, 2009 2:32 pm

adhimass wrote:First, an unexpected cascaded client window behavior:
How to recreate the problem:
  1. 1. Open two client windows by opening a picture.
    2. Click the Restore Down button (near the client close 'X' button.) The browser and view window will be cascaded. Make their windows smaller by resizing the client windows.
    3. Now open another picture. Suddenly all client window will be maximized. (This is weird #1)
    4. Now close the newly open picture. You'll see the rest of the client windows are maximized, but their contents are as large as the last resize we do on them. (This is weird #2)
I can't reproduce step 4. Client windows are maximized, but the contents is resized too.
Do you mean the contents of the image client windows or does it happen to browser window too?

You can actually disable the maximize behavior by adding MaximizeViewWhenOpen=0 in View section to your settings.
adhimass wrote:Second, a strange vertical separator appear on a maximized window of XnView in Windows Vista.
How to recreate the problem:
  1. 1. Just open the browser and preview a picture. You'll see it on the right side after the picture. Not only on the browser, it also displays when you open a picture. (This is weird #3)
Yes I have noticed this too and I think this bug is already reported.

Edit: http://newsgroup.xnview.com/viewtopic.php?t=14742 ,
http://newsgroup.xnview.com/viewtopic.php?t=13677 ,
http://newsgroup.xnview.com/viewtopic.php?t=14709 and
http://newsgroup.xnview.com/viewtopic.php?t=12238

adhimass
Posts: 5
Joined: Mon Feb 09, 2009 10:02 am
Contact:

Post by adhimass » Fri Feb 13, 2009 10:23 am

Step 4 is only applied to browser window. You have to make the browser window smaller before closing the second view window.

So there are some hidden settings in the settings file that don't appear in the Tools/Options window? Why they have to do that?

BTW, thank you for pointing me to the threads about the strange bar. There is a fix in thread http://newsgroup.xnview.com/viewtopic.php?t=14742.

Post Reply