Plantage de la 1.96.2 sur les scripts xbs

Questions générales en Français

Moderators: XnTriq, xnview

fplanglois
Posts: 63
Joined: Sun Sep 26, 2004 7:50 pm
Location: Toulouse

Plantage de la 1.96.2 sur les scripts xbs

Post by fplanglois »

Bonjour Pierre,

La version 1.96.2 plante sur presque tous les xbs créés avec les versions antérieures ou l'actuelle.
Exemple :

Code: Select all

resize( 1 lanczos 500 400 0 0 0 )
settings( 1 0 0 0 0 0 )
output_path( C:\Documents and Settings\fplanglois\Mes documents\Mes images\Tempo\preparation web\redim )
output( jpeg 76 1 0 0 0 0 1 )
plante dès le chargement du script, donc avant son exécution.

Mais

Code: Select all

resize( 1 lanczos 500 400 0 0 0 )
settings( 1 0 0 0 0 0 )

output( jpeg 76 1 0 0 0 0 1 )
ne plante pas. Visiblement un problème de chemin, qui n'existait pas sur les versions antérieures.
fplanglois
Posts: 63
Joined: Sun Sep 26, 2004 7:50 pm
Location: Toulouse

Re: Plantage de la 1.96.2 sur les scripts xbs

Post by fplanglois »

Je relance ce fil pour informer qu'après utilisation sur une autre machine, le problème ne se pose pas.

Il est donc configuration ou paramétrage dépendant. Sur la machine sur laquelle Xnview plante sur les xbs, il est installé sur le disque D.

Le problème est bien apparu avec la 1.96.2, car j'utilise ces scripts depuis longtemps.
fplanglois
Posts: 63
Joined: Sun Sep 26, 2004 7:50 pm
Location: Toulouse

Re: Plantage de la 1.96.2 sur les scripts xbs

Post by fplanglois »

J'ai tenté la désinstallation de la 196.2 et réinstallation d'une ancienne version 193.1 dont j'avais gardé l'archive.
Pas de problème.

J'ai réinstallé la 196.2 et de nouveau les plantages sur les scripts xbs avec chemin :
Image

Avez-vous une piste ?
fplanglois
Posts: 63
Joined: Sun Sep 26, 2004 7:50 pm
Location: Toulouse

Re: Plantage de la 1.96.2 sur les scripts xbs

Post by fplanglois »

Je viens d'installer la 196.5 plein d'espoirs... et plantage sur les scripts xbs. Même un simple script de redimensionnement réalisé avec la dernière version.

Comme il est clair, voir mes autres interventions, que le problème vient 1-des versions récentes 2-du chemin de sauvegarde, stocké dans le script, j'ai creusé un peu.

En sauvegardant dans un chemin très simple

Code: Select all

resize( 1 lanczos 600 400 0 1 0 )
settings( 1 0 0 0 0 0 )
output_path( C:\tempo )
output( jpeg 80 1 0 0 0 0 1 )
Toujours plantage

En modifiant à la main le fichier (ce qu'en principe on n'a pas à faire) :

Code: Select all

resize( 1 lanczos 600 400 0 1 0 )
settings( 1 0 0 0 0 0 )
output_path(C:\tempo)
output( jpeg 80 1 0 0 0 0 1 )
Ici j'ai enlevé les espaces dans le chemin, on obtient dans la fenêtre de conversion multiple répertoire de destination :

Code: Select all

output( jpeg 80 1 0 0 0 0 1
Mais au moins plus de plantage.

J'ai enfin essayé d'ajouter une ligne après le chemin :

Code: Select all

resize( 1 lanczos 600 400 0 1 0 )
settings( 1 0 0 0 0 0 )
output_path( C:\tempo )

output( jpeg 80 1 0 0 0 0 1 )
Et là tout rentre dans l'ordre.

Je soupçonne, un débordement de chaîne, un problème d'analyse syntaxique.
fplanglois
Posts: 63
Joined: Sun Sep 26, 2004 7:50 pm
Location: Toulouse

Re: Plantage de la 1.96.2 sur les scripts xbs

Post by fplanglois »

Bravo c'est bien corrigé sur la 1.97 que je viens d'installer.

C'est même signalé dans le "WhatsNew" :
Je serais curieux de connaître l'origine du problème.