Rebuild Thumbnails does not work...

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
jaqian
Posts: 61
Joined: Sat Feb 14, 2009 10:03 pm
Location: Dublin, Ireland
Contact:

Rebuild Thumbnails does not work...

Post by jaqian »

I upgraded from 1.96.1 to 1.97 and same problem exists. Anytime I scan a photo, I crop to tidy it up. I use the Rebuild Thumbnail to update the thumbnail but it never works for me under any version of XnView. I end up having to open the image in GIMP and re-save with thumbnail to sort.

Anyone else have this problem?

Cheers,
Rob
Sony Alpha α100 (Silver)
Linux Mint 7
User avatar
jaqian
Posts: 61
Joined: Sat Feb 14, 2009 10:03 pm
Location: Dublin, Ireland
Contact:

Re: Rebuild Thumbnails does not work...

Post by jaqian »

I see where I was going wrong but still confused.

I was using View - Rebuild thumbnails when I should have been using Edit - Metadata - Recreate EXIF thumbnail

My question is what is View - Rebuild thumbnails for if it doesn't work (never had for me)? And why have two similar commands even if one is broken.
Sony Alpha α100 (Silver)
Linux Mint 7
User avatar
JohnFredC
XnThusiast
Posts: 2010
Joined: Wed Mar 17, 2004 8:33 pm
Location: Sarasota Florida

Re: Rebuild Thumbnails does not work...

Post by JohnFredC »

Perhaps you have Options->Browser->Thumbnails->Appearance->Use Embedded thumbnail = ON?

If you do, and the embedded thumbnail has not yet been updated to match the image, then Rebuild thumbnails would display the (old) embedded thumbnail in the browser.
John
User avatar
jaqian
Posts: 61
Joined: Sat Feb 14, 2009 10:03 pm
Location: Dublin, Ireland
Contact:

Re: Rebuild Thumbnails does not work...

Post by jaqian »

So is View - Rebuild thumbnails a refresh for Edit - Metadata - Recreate EXIF thumbnail? Why isn't the thumbnail rebuilt automatically?
Sony Alpha α100 (Silver)
Linux Mint 7
User avatar
JohnFredC
XnThusiast
Posts: 2010
Joined: Wed Mar 17, 2004 8:33 pm
Location: Sarasota Florida

Re: Rebuild Thumbnails does not work...

Post by JohnFredC »

jaqian wrote:So is View - Rebuild thumbnails a refresh for Edit - Metadata - Recreate EXIF thumbnail?
I don't think so. Rebuild is for the thumbnail image in XnView's cache. I would say there is sufficient ambiguity about XnView's behavior that a rewording (at the least) of the menu text might be appropriate in this case.
Why isn't the thumbnail rebuilt automatically?
Good question... one idea would be: if the image was changed by an outside (i.e. non-XnView) process but without updating the embedded thumb, how would XnView "know" that the thumb was out of date? The only solution there would be to constantly rebuild all embedded thumbs, which is impractical.

Perhaps someone else will jump in with a better response? For instance, under what circumstances does XnView update the embedded thumbnail?
John
User avatar
XnTriq
Moderator & Librarian
Posts: 5616
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Rebuild Thumbnails does not work...

Post by XnTriq »

Did you enable the Auto refresh setting in Tools » Options... » Browser » Browser, jaqian?
Xyzzy ([url=http://newsgroup.xnview.com/viewtopic.php?p=23965#p23965]Options' descriptions for 1.82[/url]) wrote: Auto refresh – Automatically detects any changes in displayed directory (file additions/deletions/changes) and modifies file list accordingly.

[...]

Update Treeview when refresh - Updates also folder tree when refreshing file list with F5, CTRL+R or View->Refresh menu option, or when refreshing automatically with 'Browser>File list>Auto refresh(???).
General Support Bug Reports Suggestions Documentation Resolved Bugs & Requests
User avatar
jaqian
Posts: 61
Joined: Sat Feb 14, 2009 10:03 pm
Location: Dublin, Ireland
Contact:

Re: Rebuild Thumbnails does not work...

Post by jaqian »

XnTriq you always reply with a list of links, how do you do it so fast? Do you have a database of links to call on? :)

Autorefresh is the same as hitting F5, right? I do that anyway.

My problem was that I have rotated the thumbnails in XnView, then burnt the images to cd only to find that they aren't rotated. I think the problem is sorted now thanks to both of you.
Sony Alpha α100 (Silver)
Linux Mint 7
Post Reply